Invisible checkbox columns still take up space

14 replies. Last post: June 23, 2011 5:48 AM by Riendy Setiadi
Tags :
  • (None)
  • New Discussion
  • New Question
  • New Product Feedback

Hi,

I have a WebGrid with several hidden checkbox columns that are still taking up horizontal space, and I can't seem to find a solution.

 

The idea is to have several checkbox columns that are not visible when initially viewing the grid, but they should be available in the "Select Columns" list. According to all of the documentation I could find in the knowledge base, the recommended way to hide a column is to set Visible=false. This does hide the columns, but they still take up space (ie: if the columns are 50 pixels wide, there will be a blank area on the right side of the grid that is 50 pixels wide).

 

To get around this, I tried setting the width of the columns to 0. This fixes the issue, but then when you select the column from the list, it doesn't appear (since the width is 0).

 

NOTE: Setting Visible=false only leaves the blank space in the grid when the ColumnType is Checkbox. It seems to work for Text columns just fine.

 

Any ideas?

All times are GMT -5. The time now is 5:28 PM.